Honda Civic Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
Finally managed to sort out insurance and got the civ on the road on Wednesday eve after waiting two weeks :D . I love it...quicker than I thought itd be!

And for the typical bit that has to go wrong as its so nice getting back on the road...gave someone a lift home last night and when we stopped the temp gauge was going up. Turned the engine off and then drove on after a minute or two because it went down. Seemed to be fine so me and a mate took it down to tesco as we were just down the road as there's water down there (even though couldn't check it because it was too hot) so we could have a look under the lights.

Popped the bonnet and it was hissing away. Bit too dark to see really but guessing it's the radiator hose..mate pushed it in and the hissing stopped. Hoping didn't do any damage to the engine...pissed off :- !


Edit...just went to pick it up. Not the hose at all - radiator's absoloutely shafted...live about a mile from where I left it an had to stop four times to fill it up with water again.
 

·
Registered
Joined
·
7,629 Posts
long as you didnt boil it i would say its fine , but if you are unsure when you put the new rad on get it sniff tested at a garage , that checks for hydrocarbons in the water which is basically unburnt fuel vapour which will leak via the head gasket ,
but thats just a precautionery measure ,
also when you have run it up to temp and got all the air locks out etc , squeaze the top hose it should have pressure in it but not monster amounts ,
if you need any more info give me a shout :)
 

·
Registered
Joined
·
40 Posts
Discussion Starter #3
Thanks for that :) v helpful.

Got it sorted in the end..little bit of money for new radiator an for it to be fitted - just the job lol
 
1 - 4 of 4 Posts
Top