Honda Civic Forums banner

1 - 20 of 43 Posts

·
Premium Member
Joined
·
6,495 Posts
Discussion Starter #1
Ooooh.... how the other arf live :mrgreen:

Just opened all my presents, and would you believe.... nobody has bought me any turbo accessories / parts whatsoever :cry:
 

·
Registered
Joined
·
4,092 Posts
Re: Honda Turbo's

Nore me the bastards!

'We aren't buying you anything for that heap of shit' - nice :D
 

·
Premium Member
Joined
·
6,495 Posts
Discussion Starter #3
Re: Honda Turbo's

^ lol Thats exactly what my wife calls my car, followed by "when you selling it" :(
 

·
Registered
Joined
·
4,092 Posts
Re: Honda Turbo's

At the moment I think its a heap of shit as well lol. Just can't get the bastard thing to run properly and no idea what is causing it (now thinking its ECU problems...)

Starting to wish I had just bought a B18 instead!!
 

·
Premium Member
Joined
·
6,495 Posts
Discussion Starter #5
Re: Honda Turbo's

Whats the problem/s or symptoms your having, have you got them posted :question:
 

·
Registered
Joined
·
4,092 Posts
Re: Honda Turbo's

Whenever I run the car and rev it up it comes up to boost fine, as soon as you try to run any boost at all it sounds like its hitting a rev limiter and wont rev any higher, guessing the ECU is cutting the fuel but no idea why. This happens at exactly 0 PSI just as the system is starting to create boost.
 

·
Premium Member
Joined
·
6,495 Posts
Discussion Starter #7
Re: Honda Turbo's

Mine did that, whats your fuel pressure? you need to raise it even if you have standard injectors (mine runs about 60 PSI) and have you got a management light? does it come on?
 

·
Registered
Joined
·
4,092 Posts
Re: Honda Turbo's

I'm running prelude injectors, the EM light comes on when I turn the key but goes out after about 3 seconds once the fuel pump has finished priming. Do you think thats what it is then, low fuel pressure?

ETA: Can I raise the fuel pressure on the stock pump or do I have to buy a high flow fuel pump?
 

·
Registered
Joined
·
149 Posts
Hmm, hopefully th CRX lot won't rape you, but try on there, start a new thread.
What size are the injectors (can't remember off the top of my head) ? Other than that, FPR? Or fuel pump. At least it sounds fixable.

Don't get yourself down or lose interest, more kudos for turbo-ing than just going more cc's! It'll be worth it. :twisted:
 

·
Premium Member
Joined
·
6,495 Posts
Discussion Starter #10
Go on to ebay and by a cheap FMU (fuel pressure regulator) theres loads of them, Yeah, I think its your problem, I used standard injectors first of all (190cc) and mine would not rev past 4k, increased the pressure and it ran really well, by raising the pressure you put more fuel in the same time frame with standard ECU settings.... basically a mechanical cheat ;)

I'm still using the stock Honda pump with 265cc injectors, but will change it when I replace with 650cc :)
 

·
Premium Member
Joined
·
6,495 Posts
Discussion Starter #12
Just restrict the fuel return pipe then and try that out, as a very temporary bodge thing.

Did person you bought it off use a FMU of any sort :question:
 

·
Premium Member
Joined
·
6,495 Posts
Discussion Starter #17
What have you tried and / or checked, as I have had teething problems with Fuel Pressure, Cam Timing, Map Sensor, Spark Plug Gaps, not letting the engine get to correct temperature before making adjustments Etc...
 

·
Registered
Joined
·
4,092 Posts
I think it might be the ECU that is causing the problem, possibly a corrupt map or something. Its behaving just like a stock ECU would, cutting the fuel as soon as it sees boost.
 

·
Premium Member
Joined
·
6,495 Posts
Discussion Starter #19
I'm running stock ECU and if I go in to boost without the missing link on the map sensor it just illuminates the engine management light, but still boosts to 10psi and then shuts the juice down.
 

·
Registered
Joined
·
98 Posts
Have you checked the map sensor though? or tried another missing link check valve.

Just seems odd that as soon as it see's any boost it has problems
 
1 - 20 of 43 Posts
Top