Honda Civic Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
hi, i am just brand new to the forum this morning .i have a honda civic 1.7 ctdi 03 plate which has been giving me some problems ,and i was wondering if anybody here can shed some light on this please .the engine management light has been coming on sometimes and the car has been going into limp mode about 45mph flat out , i have had a few suggestions , some were tried some not ,but the car is still running the same way, i have also been told this is a common problem with this model .can anybody help me please,i,m at my wits end as i have already spent a bit of cash and i,m no further forward and don,t know where to go now.thanks for any information given.

Edit:

surely somebody has an idea !!!!!!!!! or am i just a newbie.
 

·
Registered
Joined
·
11 Posts
hi i am having the same problem with my car same year an specs as yours my car engine management light comes on if i accelerate to fast and then it feels as if my car has got a speed restrictor on it i have t limp home doing less than the 45 mph you get i put my foot to the floor and the power is gone my lawn mower has more power than my car.
if its a common fault with the car then i think that honda should have to rectify the problem at there cost as i see the odd car it would be different but to have a few cars with the same problem then that takes the mickey as im concerned.
the next day my car will run at full power again until you put your foot down again to over take and then it loses power again
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
alright, i have had a good turn of events on this.my young mechanic friend phoned his mate at phoenix Honda ,who told him this is a very common fault on this model .he told me to take it back to where i got it ( Arnold Clarke ),which i did and explained what was happening ,they booked it in the next day for a diagnostics.they had it for a day and a half before coming back and telling me the turbo was knackered.oh no i thought,a day and a halfs labour costs and a new turbo .but guess what the turbo has an extended warranty on it ,so i got it renewed for absolutely nothing ,i could not Adam and Eve it .i got it back yesterday and it seems to be great.i need to say this was after taking it to 3 different mechanice who all put it on the diagnostics and they all came up with a code which pointed at turbo boost censor switches and map switches ,and a regulating switch which were all replaced before i went near Arnold Clarke ,but never fixed the problem. so my advice mate take it to your Honda dealer.
 

·
Registered
Joined
·
11 Posts
i have just noticed that someone else was having the same problem as i am and he said its something to do with the fuel regulator every time i go to overtake someone the power just seems to die and the engine management light comes on and then i have to limp home.
i was wondering if you could ask you friend to ask his mate about my symptoms and see if he has any answers as i dont want to pull money out for something that dont need doing thanks from steve.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
sounds the very same problem as i was having mate.i think its when you are trying to put the foot down ,the revs go up and the turbo is meant to kick in ,but it is not ,because it is knacked.mine done it one single time way over a year ago and it could have been months before it done it again. but it got more and more frequent until it was doing it every other journey , you have nothing to lose taking it to the honda dealer and asking for a diagnostics ,if it is the turbo which i think it is ,they should cover the repair under the extended warranty the same as me ,the car is the same age too.
 
1 - 6 of 6 Posts
Top