Honda Civic Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
How hard is it to stick a D15 B2 into the ej, i'm guessing it wont be to difficult?

OMG I NEED HEEELLLLPPPP,

I got the enigne gearbox drievshaft all in, the ecu from the old eg vti, (d15b2 130bhp) but the car wont start up, with the other ecu from the ej9 (1.4 d14a4) the car starts up the variable valve timing is not right (i.e. vtec not on ecu) and it keeps jumping up and down on idle, how do i rectify this. PLEASE HELP ME!!!!![attachment=2:39slt5yd]d15b2 coming out of eg4.jpg[/attachment:39slt5yd][attachment=1:39slt5yd]ej9 civic engine out].jpg[/attachment:39slt5yd]
 

Attachments

·
Registered
Joined
·
770 Posts
well for a start the d15b2 is from a 92-95 LSi hatch and is 95hp.

the 1.5 VTi is the d15b (eg) and d15b stage 3 vtec (ek) which are JDM.

you need a OBD-2 to OBD-1 conversion harness to allow you to run the d15b2 ECU.

what loom ar you using? the d14a4 which was already in the car? or have you used the d15b2 loom?
 

·
Registered
Joined
·
29 Posts
Discussion Starter #3
This is what has gone into the ej9:

D15B
VTEC
Found in:
1991-1999 Honda Civic VTi EG4 (Japanese Market)
Displacement : 1493 cm³
Bore and Stroke : 75 mm X 84.5 mm
Rod Length : 137 mm
Compression : 9.6:1
Power : 128.22 hp (130 ps) @ 6800 rpm & 101.9 ft·lbs (14.1kg/m) @ 5200 rpm
Redline : 7200 rpm
Fuel Cut : 7411 rpm
Valvetrain : SOHC VTEC
Head Code : P08
Fuel Control : OBD-1 MPFI

the ecu i have in the ej9 already only has 2 slots on the ecu and one above, i'll take a pic of it wen i get to the garage. The ecu that is in the VTi is a OBD-0 as far as i remember i know it only has 2 plug slots on it, do i still need to get the OBD-2 to OBD-1 conversion harness or do i need a different one now?

I'm using the loom from the d14 as i have the d14 inlet manifold on the d15 engine, due to there being too much chop changing to the existing inlet manifold if i wanted to use it, (which i did :( )
 

·
Registered
Joined
·
770 Posts
yea you need a conversion harness so the d15b ECU will plug into the d14a4 loom.

but have the d14a4 sensors on the IM might cause a problem.

where did you get the engine from?
 

·
Registered
Joined
·
29 Posts
Discussion Starter #5
I got the engine from my eg, it got wrote off and i bought the ej9 and put the engine into it. What sort of problems might i have have with the IM sensors? I can get the car started but it just jumps up and down on idle. URGH frustrating me so much.
 

·
Registered
Joined
·
770 Posts
well im not sure your D15 ECU will like reading the D14 sensor signals, but i might be wrong.

what happens when you try an rev it in neutral?
 

·
Registered
Joined
·
29 Posts
Discussion Starter #7
It revs up fine, no problems at all, But the engine check light is on and the idle keeps jumping up and down when im not reving in neutral.

Right, i have found that i am Using a P3Y ecu on my d15b jdm engine, obviously i need to use my P08 ecu from the previous car, the loom is from the d14a4, does anyone know how i can change it so it plugs into the P08, (what modification will i need to carry out for it to work, considering ive tried plug and play with it allready and it doesn't turn over).

Edit:

any ideas anyone?
 
1 - 7 of 7 Posts
Top