Honda Civic Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
206 Posts
Discussion Starter #1
i was wheel spinning last night :redface: and my speedo has stopped working and my engine isnt idling right anymore, it used to sit at about 1000 but now its between 50-100 :cry: :cry: :cry:
 

·
Registered
Joined
·
770 Posts
Re: weird idling and broken speedo??

well serves you right for being a chav lol

the speedometer works off a sensor on top of the tranny, its easily accessible. get a haynes and it will tell you how to check it.

im not sure if it would cause the car car idle bad though.
 

·
Registered
Joined
·
206 Posts
Discussion Starter #7
Re: weird idling and broken speedo??

lol, on the way home from work my car died, no power in the battery!!! so i rang RAC, id definatley recomend them to anyone with a car, ive used them about 6 times in the last 2 years!!!! after a few seconds the guy realises that the battery isnt charging, he identified the problems as

- the fuse that controls the speedo and the alternator had poped

so we tried another fuse and it poped again, disconected the speedo sensor and put another fuse in and the fuse didnt pop, so i thought yey its fixed! got home and while trying to park the engine died again due to the powersteering pump draining the power, so i go to turn the car back on and the battery light had gone off again, so checked the fuse and it popped again??????? so ive put another one in and its outside on tickover hopefully charging, the speedo sensor is disconnected and im gettting another one this weekend

so ive got two questions

1) will it pop again? if so whats wrong with it?
2) will it charge on tick over?

please help guys, im definatley in over my depth lol
 
1 - 7 of 7 Posts
Top